ubuntu 16.04安装多版本PHP相互切换

1.安装之后可以减少许多因语言编码带来的问题
apt install -y language-pack-en-base 
2.设定语言编码为UTF-8
LC_ALL=en_US.UTF-8
3.安装php源
add-apt-repository ppa:ondrej/php
4.安装php常用组件,按照需要替换相关版本号即可。
apt-get install php5.6 libapache2-mod-php5.6 php5.6-mysql php5.6-curl php5.6-gd php5.6-intl php5.6-imap php5.6-mcrypt  php5.6-pspell php5.6-recode php5.6-tidy php5.6-xml php5.6-xsl php5.6-json php5.6-cgi php5.6-mbstring php5.6-gettext php5.6-zip
5.禁用php版本
a2dismod php7.1
6.启用php版本
a2enmod php5.6
7.重启apache服务
service apache2 restart
一个优秀的站点,极致体验,本站下载无插件、无后门承诺。
偶遇 » ubuntu 16.04安装多版本PHP相互切换

Leave a Reply

一个另你着迷的站点

购买